股城网,免费股票公式,股票软件下载站 用户登录  |  用户 注册
资金主图,仿造同名的L2行情公式,需要L2行情支持(通达信公式 主图 源码 测试图)
  • 软件大小:7.00 KB
  • 推荐星级:
  • 更新时间:2020-06-06 00:12:22
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 免费版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/Win7/
  • 相关Tags:资金  
  • (0)0%
    (0)0%

软件介绍

 资金主图 

本公式是仿造同名的L2行情公式,需要L2行情支持
各数据的计算公式均出自于网络各个指标,我只是将他们由零碎的拼成了一个还能称得主图指标的指标。

{资金主图}
{需要LEVEL-2行情}
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,60);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORCYAN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORCYAN;
操盘线:MA(CLOSE,9),COLORYELLOW;
界点线:MA(CLOSE,20),COLORMAGENTA;
高:=REF(HHV(H,80),3);
低:=REF(LLV(L,80),3);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),POINTDOT,COLORWHITE;
疯牛:=REFDATE(H19,DATE),POINTDOT,COLORYELLOW;
突破:REFDATE(H38,DATE),POINTDOT,COLORMAGENTA;
平衡:REFDATE(H中,DATE),POINTDOT,COLORRED;
回落:REFDATE(H61,DATE),POINTDOT,COLORGREEN;
低点:=REFDATE(低,DATE),POINTDOT,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,顶点),COLORWHITE;
DRAWTEXT(ISLASTBAR,低点,低点),COLORWHITE;
{主图资金模块}
超B:=L2_AMO(0,2)/1000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
JGV:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/100000000,COLORRED;
DHV:=(L2_VOL(1,0) - L2_VOL(1,1))*VOL/100000000,COLORFF00FF;
ZHV:=(L2_VOL(2,0) - L2_VOL(2,1))*VOL/100000000,COLOR00FFFF;
SHV:=(L2_VOL(3,0) - L2_VOL(3,1))*VOL/100000000,COLORFFFFFF;
大量博弈:=(JGV+DHV),COLORYELLOW,NODRAW;
 
大宗净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S);
大宗进:=(超B)+(大B);
大宗出:=(超S)+(大S);
非大宗进:=(中B)+(小B);
非大宗出:=(中S)+(小S);
成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;
 
{右上角横柱}
主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买:主买A*100/(主买A+主卖A),NODRAW,COLORRED;
主卖:主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;
 
大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;
大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);
DRAWRECTREL(650,60,885,120,RGB(0,100,0));
DRAWRECTREL(650,60,885,120,RGB(0,150,150));
DRAWRECTREL(650,60,650+CONST(大单流入限制*235/100),120,RGB(200,0,50));
DRAWTEXT_FIX(1,0.565,0.06,0,STRCAT(STRCAT('大单流入比    ',CON2STR(大单流入限制,2)),'%')),COLORYELLOW;
 
大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度限制:=IF(大单强度<=0,ABS(大单强度),IF(大单强度>=100,100,大单强度));
DRAWRECTREL(650,130,885,190,RGB(0,100,0));
DRAWRECTREL(650,130,885,190,RGB(0,250,50));
DRAWRECTREL(650,130,650+CONST(大单强度限制*235/100),190,RGB(175,50,250));
DRAWTEXT_FIX(1,0.565,0.136,0,STRCAT(STRCAT('大单强度比    ',CON2STR(大单强度,2)),'%')),COLORYELLOW;
 
总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
DRAWRECTREL(650,200,885,260,RGB(0,100,0));
DRAWRECTREL(650,200,885,260,RGB(0,150,150));
DRAWRECTREL(650,200,650+CONST(总流入比*235/100),260,RGB(200,0,50));
DRAWTEXT_FIX(1,0.565,0.206,0,STRCAT(STRCAT('资金流入比    ',CON2STR(总流入比,2)),'%')),COLORYELLOW;
 
MVR:=REF(MA(V,5),1);
FVR:=REF(V,1);
PVR:=(MVR+FVR)/2;
资金量能比:=V/(V+PVR)*100/FROMOPEN*240;
DRAWRECTREL(650,270,885,330,RGB(0,100,0));
DRAWRECTREL(650,270,885,330,RGB(0,250,50));
DRAWRECTREL(650,270,650+CONST(资金量能比*235/100),330,RGB(175,50,250));
DRAWTEXT_FIX(1,0.565,0.276,0,STRCAT(STRCAT('资金量能比    ',CON2STR(资金量能比,2)),'%')),COLORYELLOW;
 
{左上角横柱}
主力买力度:=LARGEINTRDVOL*100/VOL,NODRAW;
主力卖力度:=LARGEOUTTRDVOL*100/VOL,NODRAW;
买卖力度比:=IF(主力买力度/主力卖力度*100>=100,100,IF(主力买力度/主力卖力度*100<=0,0,主力买力度/主力卖力度*100));
DRAWRECTREL(95,60,330,120,RGB(0,75,200));
DRAWRECTREL(95,60,330,120,RGB(0,150,150));
DRAWRECTREL(95,60,95+CONST(买卖力度比*235/100),120,RGB(200,0,50));
DRAWTEXT_FIX(1,0.013,0.06,0,STRCAT(STRCAT('买卖力度比    ',CON2STR(主力买力度/主力卖力度*100,2)),'%')),COLORYELLOW;
 
大量资金比:=大量博弈/(ABS(JGV)+ABS(DHV)+ABS(ZHV)+ABS(SHV))*100,COLORYELLOW,NODRAW;
大量资金比限制:=IF(大量资金比=0,-100,大量资金比);
大量强度比:=IF(大量资金比>0,(大量资金比限制+100)/2,IF(大量资金比<0,100-ABS((大量资金比限制-100)/2),0)),COLORGREEN,NODRAW;
DRAWRECTREL(95,130,330,190,RGB(0,75,220));
DRAWRECTREL(95,130,330,190,RGB(0,250,50));
DRAWRECTREL(95,130,95+CONST(大量强度比*235/100),190,RGB(175,50,250));
DRAWTEXT_FIX(1,0.013,0.136,0,STRCAT(STRCAT('大量强度比    ',CON2STR(大量强度比,2)),'%')),COLORYELLOW;
 
主买C:=主买A*100/(主买A+主卖A),NODRAW,COLORRED;
DRAWRECTREL(95,200,330,260,RGB(0,75,200));
DRAWRECTREL(95,200,330,260,RGB(0,150,150));
DRAWRECTREL(95,200,95+CONST(主买C*235/100),260,RGB(200,0,50));
DRAWTEXT_FIX(1,0.013,0.206,0,STRCAT(STRCAT('主动买卖比    ',CON2STR(主买C,2)),'%')),COLORYELLOW;
 
机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;
DRAWRECTREL(95,270,330,330,RGB(0,75,220));
DRAWRECTREL(95,270,330,330,RGB(0,250,50));
DRAWRECTREL(95,270,95+CONST(机构参与度*235/100),330,RGB(175,50,250));
DRAWTEXT_FIX(1,0.013,0.276,0,STRCAT(STRCAT('机构参与度    ',CON2STR(机构参与度,2)),'%')),COLORYELLOW;
 
活跃度:=100*VOL/(FINANCE(7)/100)COLORYELLOW,NODRAW;
DRAWRECTREL(460,800,695,860,RGB(0,75,220));
DRAWRECTREL(460,800,695,860,RGB(0,250,50));
DRAWRECTREL(460,800,460+CONST(活跃度*235/100),860,RGB(255,147,38));
DRAWTEXT_FIX(1,0.41,0.81,0,STRCAT(STRCAT('活跃度    ',CON2STR(活跃度,2)),'%')),COLORYELLOW;
 
饱和度:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWRECTREL(460,870,695,930,RGB(0,75,220));
DRAWRECTREL(460,870,695,930,RGB(0,250,50));
DRAWRECTREL(460,870,460+CONST(饱和度*235/100),930,RGB(255,147,38));
DRAWTEXT_FIX(1,0.41,0.876,0,STRCAT(STRCAT('饱和度    ',CON2STR(饱和度,2)),'%')),COLORYELLOW;
 
{左下角竖柱}
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(20,CONST(950-(ABS(净流入)*250/DAZHIV)),60,950,IF(CONST(净流入)>0,RGB(250,0,0),RGB(0,250,0)));
DRAWRECTREL(85,CONST(950-(ABS(大宗进)*250/DAZHIV)),125,950,IF(CONST(大宗进)>0,RGB(255,0,255),RGB(0,0,50)));
DRAWRECTREL(150,CONST(950-(ABS(大宗出)*250/DAZHIV)),190,950,IF(CONST(大宗出)>0,RGB(50,50,255),RGB(255,0,0)));
DRAWRECTREL(215,CONST(950-(ABS(非大宗进)*250/DAZHIV)),255,950,IF(CONST(非大宗进)>0,RGB(250,0,250),RGB(0,0,50)));
DRAWRECTREL(280,CONST(950-(ABS(非大宗出)*250/DAZHIV)),320,950,IF(CONST(非大宗出)>0,RGB(50,50,250),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,1,0,' 资金驱动    主力进     主力出     散户进     散户出'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.02,0.68,0,'净流入'),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.02,0.88,0,INTPART(净流入)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.085,0.88,0,INTPART(大宗进)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.150,0.88,0,INTPART(大宗出)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.215,0.88,0,INTPART(非大宗进)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.278,0.88,0,INTPART(非大宗出)),COLORWHITE;
 
{画涨停板}
AA:=FRACPART(10*REF(CLOSE,1));
BB:=IF(AA>=0.5,AA+0.1,AA);
CC:=0.01*INTPART(10*REF(CLOSE,1))+0.01*ROUND(BB);
涨停板:=REF(CLOSE,1)+CC;
STICKLINE(CLOSE=涨停板,OPEN,CLOSE,1,0),COLORYELLOW;
 
 

下载地址(点击下图进入下载地址网页)

    资金主图,仿造同名的L2行情公式,需要L2行情支持(通达信公式 主图 源码 测试图)下载

软件评论评论内容只代表网友观点,与本站立场无关!

   评论摘要(共 0 条,得分 0 分,平均 0 分) 查看完整评论

下载说明

* 下载方法:点击上面的绿色图片(图片有“下载地址”文字),就新开一个页面,点击“本地高速下载”,或者点击文字“下载地址1”即可下载软件 * 本网站提供的各种股票软件,例如大智慧软件,通达信软件,同花顺软件,飞狐,文华期货软件,手机炒股软件,指南针,东方财富通等等,和各种股票公式指标,例如大智慧公式,通达信公式,同花顺公式,操盘手公式,文华公式,飞狐公式,博易大师公式,股票价格计算公式等等公式指标,还有各类股票书籍都来源网上可以免费下载
* 请一定升级到最新版WinRAR才能正常解压本站提供的软件!

本网提供的公式文件说明:
* alg格式飞狐股票公式,可以用飞狐交易师或者交易师软件导入;
* fnc格式大智慧新一代公式指标,可以用大智慧股票软件使用,少部分可以用分析家股票软件引入使用;
* exp格式大智慧经典版股票公式,仅可以用大智慧经典版股票软件引入使用;
* tni和tnc格式通达信股票公式,仅可以用通达信新引入使用,例如可以用通达信股票软件引入使用;
* tne,tn6格式通达信公式,可以用通达信公式编辑器5.0版导入,推荐通达信金融终端版本;
* hxf格式同花顺股票公式,仅可以用同花顺股票软件引入使用。
以上的各种软件都可以在本网股票软件栏目找到并下载!

* 关于股票公式时间限制,如果在引入大智慧公式,交易师公式或者飞狐公式的时候,发现公式名称栏是空白的,这时候调整电脑时间到1997年,又能出现公式名称,并且能正常显示,可能是公式使用期限已过。
* 关于公式解密收费解密大智慧公式,通达信公式,同花顺公式,操盘手公式,飞狐公式,博易大师公式,文华公式和外汇EA等等源码,可解密完全加密定向加密公式或延时,收费服务无意勿扰,联系QQ。

* 关于股票公式源码编辑
本网提供的源码,一般都可以编辑成公式,如果不明白公式的编辑,在本页右侧教程录像可参考,或者找公式教程资料学习,请搜索:教程

* 如果您发现下载链接错误,请点击报告错误谢谢!
* 站内提供的所有软件包含和谐及注册码均是由网上搜集,若侵犯了你的版权利益,敬请来信通知我们!

关于本站 | 网站帮助 | 广告合作 | 下载声明 | 友情连接 | 网站地图 |

股城网声明:本站所有股票公式、股票软件、股票书籍均免费。站内所有广告,如有收费行为,均与本站无关!请网友小心谨慎。
Copyright © 2003-2008 . All Rights Reserved .
页面执行时间:156.25000 毫秒